CatManD3W SC300 Ongoing Build... - Page 15 - Club Lexus Forums

Log In 

CatManD3W SC300 Ongoing Build...

Reply
 
 
 
Thread Tools Search this Thread
Old 04-26-14, 04:09 PM   #211
lilSCsteve
Moderator
iTrader: (66)
 
lilSCsteve's Avatar
 
Join Date: Sep 2008
Location: NC
Posts: 3,206
Default

YES! YES! YES! It's alive!

steve
lilSCsteve is offline   Reply With Quote
Old 04-26-14, 04:34 PM   #212
1JZPWRD
1JZ Single SC400
iTrader: (59)
 
1JZPWRD's Avatar
 
Join Date: Jan 2009
Location: Alabama, Roll Tide!
Posts: 8,500
Default

Glad to see it finally running. Gerrb can fix and figure out anything. He is a known go to guy. Now what's left?
1JZPWRD is offline   Reply With Quote
Old 04-28-14, 07:33 AM   #213
CatManD3W
Lexus Champion
Thread Starter
iTrader: (17)
 
CatManD3W's Avatar
 
Join Date: May 2013
Location: SteelCity
Posts: 1,994
Default

Some pics of the SC finally getting out of the garage and drivable...

The wheels are hard to see lol...I like the side pic with the lugnuts really stand out against the wheels









I still need to work on getting the hood aligned a little better....and yes I know it need a drop..



Here a video of with the Innovative Wideband.......How does the air fuel ratio look.....good?


Last edited by CatManD3W; 04-28-14 at 08:30 PM.
CatManD3W is offline   Reply With Quote
Old 04-28-14, 09:11 AM   #214
CatManD3W
Lexus Champion
Thread Starter
iTrader: (17)
 
CatManD3W's Avatar
 
Join Date: May 2013
Location: SteelCity
Posts: 1,994
Default

FYI......I can hear the turbo start to come on around 2800 RPM......and it peaks at 12 psi around 4500...i.e I can hear wastegate....

It has really quick spool and when you get into 3000 RPM and above it pulls really hard and fast....

Stay tuned for some videos....I need to get the suction cup mount so I can use my GoPro
CatManD3W is offline   Reply With Quote
Old 04-28-14, 06:04 PM   #215
1JZPWRD
1JZ Single SC400
iTrader: (59)
 
1JZPWRD's Avatar
 
Join Date: Jan 2009
Location: Alabama, Roll Tide!
Posts: 8,500
Default

The wideband IMO looks good. Alot better than mine. I am extremely rich at idle. Mine is 10.6 - 12.3 depends if the AC is on or not.
1JZPWRD is offline   Reply With Quote
Old 04-28-14, 08:28 PM   #216
CatManD3W
Lexus Champion
Thread Starter
iTrader: (17)
 
CatManD3W's Avatar
 
Join Date: May 2013
Location: SteelCity
Posts: 1,994
Default

Quote:
Originally Posted by 1JZPWRD View Post
The wideband IMO looks good. Alot better than mine. I am extremely rich at idle. Mine is 10.6 - 12.3 depends if the AC is on or not.
Ok cool....im still on stock ECU and 440's
CatManD3W is offline   Reply With Quote
Old 04-29-14, 05:58 PM   #217
CatManD3W
Lexus Champion
Thread Starter
iTrader: (17)
 
CatManD3W's Avatar
 
Join Date: May 2013
Location: SteelCity
Posts: 1,994
Default

Hey guys I am unable to get my speedo to work....I am using W58

I have it wired up correctly per wiring diagrams:

Pin 1 of Speed Sensor to pin 10 of IJ1
Pin 2 of Speed Sensor to pin 6 of IK1
Pin 3 of Speed Sensor to pin 7 of IK1





Also my odometer is not increasing eihter....it is staying the same amount of miles...

Any input guys would help out a lot....

Last edited by CatManD3W; 04-29-14 at 06:07 PM.
CatManD3W is offline   Reply With Quote
Old 04-30-14, 08:55 AM   #218
CatManD3W
Lexus Champion
Thread Starter
iTrader: (17)
 
CatManD3W's Avatar
 
Join Date: May 2013
Location: SteelCity
Posts: 1,994
Default

Still trying to figure out what is up with the speedometer and odometer....

Here is my $6 dump tube for wastegate......



It is raining all day today....but it is nice to see both of my rides out front getting a bath...

CatManD3W is offline   Reply With Quote
Old 05-02-14, 06:48 AM   #219
CatManD3W
Lexus Champion
Thread Starter
iTrader: (17)
 
CatManD3W's Avatar
 
Join Date: May 2013
Location: SteelCity
Posts: 1,994
Default

Boost and Wideband gauges mounted onto steering column using Auto Meter 2204 Universal Gauge pods...I never understood why so man people put the gauges where you cant easy see them...I am using Innovative Motorsports MTX-L Wideband and Boost Gauge.

BTW...Wideband gauge is reading 22.4 because the car isnt running...





CatManD3W is offline   Reply With Quote
Old 05-05-14, 01:45 PM   #220
CatManD3W
Lexus Champion
Thread Starter
iTrader: (17)
 
CatManD3W's Avatar
 
Join Date: May 2013
Location: SteelCity
Posts: 1,994
Default

Everything is up and running good....Wanted to let everyone know that I have not encountered any issues as of yet....

I need to finish up my interior....ever since I have been able to drive the car I have been to busy enjoying boost........It is supposed to start getting nicer again at end of week so look for updates then....
CatManD3W is offline   Reply With Quote
Old 05-05-14, 04:28 PM   #221
oldManTan
Lexus Champion
 
Join Date: Jan 2014
Location: illinois
Posts: 1,843
Default

mmmm cant wait to hear some drivebys and driving shots. looking forward to this man!!! again nice job on the build.
oldManTan is offline   Reply With Quote
Old 05-07-14, 02:46 PM   #222
CatManD3W
Lexus Champion
Thread Starter
iTrader: (17)
 
CatManD3W's Avatar
 
Join Date: May 2013
Location: SteelCity
Posts: 1,994
Default

Quote:
Originally Posted by oldManTan View Post
mmmm cant wait to hear some drivebys and driving shots. looking forward to this man!!! again nice job on the build.
I will get some videos soon....Thanks...
CatManD3W is offline   Reply With Quote
Old 05-08-14, 10:56 AM   #223
CatManD3W
Lexus Champion
Thread Starter
iTrader: (17)
 
CatManD3W's Avatar
 
Join Date: May 2013
Location: SteelCity
Posts: 1,994
Default

Little 5 min video on my GoPro to give you an idea of what it sounds like....I am not really pushing it to hard yet....And was a lot of cars on the road in front of me


Last edited by CatManD3W; 05-08-14 at 11:16 AM.
CatManD3W is offline   Reply With Quote
Old 05-08-14, 01:30 PM   #224
bigwes
Lexus Test Driver
 
Join Date: Apr 2012
Location: TX
Posts: 1,135
Default

sounds like a ton of fun to drive. i need a 2J
bigwes is offline   Reply With Quote
Old 05-08-14, 02:23 PM   #225
Tabaka
Lexus Champion
iTrader: (8)
 
Join Date: Mar 2010
Location: Dale City, VA
Posts: 3,808
Default

What EMS do you have?
Tabaka is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Feb 2015...Mini Photoshop....Update CatManD3W SC- 1st Gen (1992-2000) 13 02-13-15 10:50 AM
Two 2jzgte swapped SC's Have A Play Date CatManD3W SC- 1st Gen (1992-2000) 22 08-13-14 07:43 PM
PA *MINT* 92 Tail lights w/ harnesses CatManD3W SC400 / 300 Classifieds 1 07-21-14 09:10 AM
Mini Photoshoot..... CatManD3W SC- 1st Gen (1992-2000) 4 06-05-14 01:51 PM
Finally landed myself a clean SC300!! CatManD3W SC- 1st Gen (1992-2000) 22 07-11-13 12:35 AM


Tags
15x7, lexus, rx300, sale, sc300, transmission, w58, wheels

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 03:15 AM.


Copyright © 2000-2016 Internet Brands, Inc. All Rights Reserved